PERFORCE change 75891 for review
Robert Watson
rwatson at FreeBSD.org
Sun Apr 24 16:26:51 GMT 2005
http://perforce.freebsd.org/chv.cgi?CH=75891
Change 75891 by rwatson at rwatson_paprika on 2005/04/24 16:26:04
Rename MAX_GROUPS to BSM_MAX_GROUPS to avoid name space pollution.
Affected files ...
.. //depot/projects/trustedbsd/openbsm/bsm/audit_record.h#5 edit
.. //depot/projects/trustedbsd/openbsm/libbsm/bsm_token.c#5 edit
.. //depot/projects/trustedbsd/openbsm/libbsm/libbsm.h#6 edit
Differences ...
==== //depot/projects/trustedbsd/openbsm/bsm/audit_record.h#5 (text+ko) ====
@@ -211,7 +211,7 @@
#define PAD_FAILURE 0x8000 /* fail audit event */
-#define MAX_GROUPS 16
+#define BSM_MAX_GROUPS 16
#define HEADER_VERSION 1
#define TRAILER_PAD_MAGIC 0xB105
==== //depot/projects/trustedbsd/openbsm/libbsm/bsm_token.c#5 (text+ko) ====
@@ -271,7 +271,7 @@
*/
token_t *au_to_groups(int *groups)
{
- return au_to_newgroups(MAX_GROUPS, groups);
+ return au_to_newgroups(BSM_MAX_GROUPS, groups);
}
/*
==== //depot/projects/trustedbsd/openbsm/libbsm/libbsm.h#6 (text+ko) ====
@@ -308,7 +308,7 @@
typedef struct {
u_int16_t no;
- u_int32_t list[MAX_GROUPS];
+ u_int32_t list[BSM_MAX_GROUPS];
} au_groups_t;
To Unsubscribe: send mail to majordomo at trustedbsd.org
with "unsubscribe trustedbsd-cvs" in the body of the message
More information about the trustedbsd-cvs
mailing list