PERFORCE change 15218 for review
Robert Watson
rwatson at freebsd.org
Tue Jul 30 20:06:18 GMT 2002
http://people.freebsd.org/~peter/p4db/chv.cgi?CH=15218
Change 15218 by rwatson at rwatson_tislabs on 2002/07/30 13:06:17
Remove duplicated code from trustedbsd_base that came in during
the integ.
Affected files ...
.. //depot/projects/trustedbsd/mac/sys/kern/uipc_mbuf.c#10 edit
Differences ...
==== //depot/projects/trustedbsd/mac/sys/kern/uipc_mbuf.c#10 (text+ko) ====
@@ -64,6 +64,11 @@
SYSCTL_INT(_kern_ipc, KIPC_MAX_DATALEN, max_datalen, CTLFLAG_RW,
&max_datalen, 0, "");
+/*
+ * Copy mbuf pkthdr from "from" to "to".
+ * "from" must have M_PKTHDR set, and "to" must be empty.
+ * aux pointer will be moved to "to".
+ */
void
m_copy_pkthdr(struct mbuf *to, struct mbuf *from)
{
@@ -87,25 +92,6 @@
}
/*
- * Copy mbuf pkthdr from "from" to "to".
- * "from" must have M_PKTHDR set, and "to" must be empty.
- * aux pointer will be moved to "to".
- */
-void
-m_copy_pkthdr(struct mbuf *to, struct mbuf *from)
-{
-
-#if 0
- KASSERT(to->m_flags & M_PKTHDR,
- ("m_copy_pkthdr() called on non-header"));
-#endif
- to->m_data = to->m_pktdat;
- to->m_flags = from->m_flags & M_COPYFLAGS;
- to->m_pkthdr = from->m_pkthdr;
- from->m_pkthdr.aux = NULL;
-}
-
-/*
* Lesser-used path for M_PREPEND:
* allocate new mbuf to prepend to chain,
* copy junk along.
To Unsubscribe: send mail to majordomo at trustedbsd.org
with "unsubscribe trustedbsd-cvs" in the body of the message
More information about the trustedbsd-cvs
mailing list