svn commit: r249689 - stable/9/sys/cddl/contrib/opensolaris/uts/common/fs/zfs
Martin Matuska
mm at FreeBSD.org
Sat Apr 20 09:25:25 UTC 2013
Author: mm
Date: Sat Apr 20 09:25:25 2013
New Revision: 249689
URL: http://svnweb.freebsd.org/changeset/base/249689
Log:
MFC r249047 (avg):
spa_open_common: fix argument to zvol_create_minors
Prior to r248571 spa_open was always called with a bare pool name,
but now it is called with a dataset name instead (spa_lookup handles
that).
So, when a ZFS root is mounted spa_open is called with a name of a root
dataset, which can very well be different from the pool name.
But zvol_create_minors should be called with the pool name, because it
performs a recursive traversal of all datasets under the name to find
all those that are volumes.
Modified:
stable/9/sys/cddl/contrib/opensolaris/uts/common/fs/zfs/spa.c
Directory Properties:
stable/9/sys/ (props changed)
stable/9/sys/cddl/contrib/opensolaris/ (props changed)
Modified: stable/9/sys/cddl/contrib/opensolaris/uts/common/fs/zfs/spa.c
==============================================================================
--- stable/9/sys/cddl/contrib/opensolaris/uts/common/fs/zfs/spa.c Sat Apr 20 08:25:14 2013 (r249688)
+++ stable/9/sys/cddl/contrib/opensolaris/uts/common/fs/zfs/spa.c Sat Apr 20 09:25:25 2013 (r249689)
@@ -2870,7 +2870,7 @@ spa_open_common(const char *pool, spa_t
#ifdef __FreeBSD__
#ifdef _KERNEL
if (firstopen)
- zvol_create_minors(pool);
+ zvol_create_minors(spa->spa_name);
#endif
#endif
}
More information about the svn-src-stable-9
mailing list