svn commit: r345350 - in head: . lib/libjail sbin/mount_fusefs sys/conf sys/fs/fuse sys/modules sys/modules/fuse sys/modules/fusefs
Alan Somers
asomers at freebsd.org
Wed Mar 20 22:35:04 UTC 2019
On Wed, Mar 20, 2019 at 4:23 PM Pedro Giffuni <pfg at freebsd.org> wrote:
>
>
> On 20/03/2019 16:48, Alan Somers wrote:
> > Author: asomers
> > Date: Wed Mar 20 21:48:43 2019
> > New Revision: 345350
> > URL: https://svnweb.freebsd.org/changeset/base/345350
> >
> > Log:
> > Rename fuse(4) to fusefs(4)
> >
> > This makes it more consistent with other filesystems, which all end in "fs",
> > and more consistent with its mount helper, which is already named
> > "mount_fusefs".
> >
> > Reviewed by: cem, rgrimes
> > MFC after: 2 weeks
> > Sponsored by: The FreeBSD Foundation
> > Differential Revision: https://reviews.freebsd.org/D19649
> >
> > Added:
> > head/sys/modules/fusefs/
> > - copied from r345349, head/sys/modules/fuse/
> > Deleted:
> > head/sys/modules/fuse/
> > Modified:
> > head/UPDATING
> > head/lib/libjail/jail.c
> > head/sbin/mount_fusefs/mount_fusefs.c
> > head/sys/conf/NOTES
> > head/sys/conf/files
> > head/sys/conf/options
> > head/sys/fs/fuse/fuse.h
> > head/sys/fs/fuse/fuse_file.c
> > head/sys/fs/fuse/fuse_ipc.c
> > head/sys/fs/fuse/fuse_main.c
> > head/sys/fs/fuse/fuse_node.c
> > head/sys/fs/fuse/fuse_vfsops.c
> > head/sys/fs/fuse/fuse_vnops.c
> > head/sys/modules/Makefile
> > head/sys/modules/fusefs/Makefile
>
>
> Hmm..
>
> Not that it matters but you renamed the module, shouldn't you rename the
> directory as well?
>
> We have sys/fs/{deadfs|devfs|ext2fs|fdescfs|fifofs|msdosfs| ... etcfs}.
>
> Cheers,
>
> Pedro.
Technically it's not a requirement for the build, and my other
reviewer requested that I don't just to reduce repo churn.
-Alan
More information about the svn-src-all
mailing list