svn commit: r382905 - in head/sysutils: qjail qjail2
Alexey Dokuchaev
danfe at FreeBSD.org
Wed Apr 1 11:41:28 UTC 2015
On Wed, Apr 01, 2015 at 11:35:52AM +0000, Ryan Steinmetz wrote:
> New Revision: 382905
> URL: https://svnweb.freebsd.org/changeset/ports/382905
>
> [...]
> @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
> - @(cd ${WRKSRC}/examples/ \
> + (cd ${WRKSRC}/examples/ \
> && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR})
Using dot (.) instead of \* is shorter, more readable, and less error-prone
(no need to think about escaping). That's why it is recommended by the PHB.
Since you've touched that command, you might have considered fixing this as
well.
> @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
> - @(cd ${WRKSRC}/examples/ \
> + (cd ${WRKSRC}/examples/ \
> && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR})
Ditto. Also, notice bogus indentation of the backslash.
./danfe
More information about the svn-ports-head
mailing list