svn commit: r373100 - in head: . Mk databases/glom databases/libzdb databases/opendbx databases/pglesslog databases/qt4-pgsql-plugin databases/qt5-sqldrivers-pgsql databases/rubygem-do_postgres dat...
Adam Weinberger
adamw at adamw.org
Sat Nov 22 21:49:26 UTC 2014
> On 22 Nov, 2014, at 14:44, Chris Rees <crees at physics.org> wrote:
>
> On 22/11/2014 21:31, Adam Weinberger wrote:
>> On 22 Nov, 2014, at 13:40, Chris Rees <crees at FreeBSD.org> wrote:
>>> Author: crees
>>> Date: Sat Nov 22 20:40:08 2014
>>> New Revision: 373100
>>> URL: https://svnweb.freebsd.org/changeset/ports/373100
>>> QAT: https://qat.redports.org/buildarchive/r373100/
>>>
>>> Log:
>>> Finally retire USE_PGSQL
>>>
>>> + USE_PGSQL=server becomes USES=pgsql and WANT_PGSQL=server
>> USES=perl5 has USE_PERL5, USES=python has USE_PYTHON, USES=openal has USE_OPENAL, USES=fam has USE_FAM.
>>
>> Why is pgsql WANT_ instead of USE_?
>
> Hm. A couple of reasons really; USE_PGSQL was used before by bsd.database.mk, and with the two coexisting perhaps sharing the variable was not desired; I remember back in December last year when writing this that people weren't keen on separate variables at all, preferring to use arguments to USES. During that discussion, no-one mentioned that WANT_PGSQL wasn't desirable (perhaps it wasn't even discussed).
>
> I could rename it to USE_PGSQL now the code is removed from bsd.database.mk I suppose... but is it necessary? I don't personally think it's a great idea to reuse variables that used to mean something else...
Definitely makes sense not to use USE_PGSQL while the transition is underway. But now that the transition is complete, USE_PGSQL is a NOOP unless USES=pgsql is there, no? So if somebody tried to do USE_PGSQL=yes it wouldn't work, same as it won't work now.
My suggestion would always be to aim for consistency across the different USES modules, but I can't even begin to guess how much work it took to get the USES=pgsql transition done!
# Adam
--
Adam Weinberger
adamw at adamw.org
http://www.adamw.org
More information about the svn-ports-head
mailing list