svn commit: r317890 - head/sysutils/less
Alexey Dokuchaev
danfe at FreeBSD.org
Sun May 12 04:30:14 UTC 2013
On Sat, May 11, 2013 at 03:37:56PM +0000, Wen Heping wrote:
> New Revision: 317890
> URL: http://svnweb.freebsd.org/changeset/ports/317890
>
> @@ -11,18 +11,23 @@ MASTER_SITE_SUBDIR= less
> MAINTAINER= jharris at widomaker.com
> COMMENT= A better pager utility
You could have trimmed indefinite article from COMMENT while you're here.
> +LICENSE= GPLv3
> +
> +OPTIONS_DEFINE= COLOR_LESS
> +COLOR_LESS_DESC=Enables color support via escape sequence
This is a poorly chosen knob name: in English, it would rather mean "less(1)
without colors" (= colorless) than "color-enabled less(1)". I would suggest
you rename it to just "COLORS" or "COLOR_SUPPORT" (a bit too long I guess).
Also notice missing tab after COLOR_LESS_DESC= -- I assume it was dropped
because COLOR_LESS_DESC= is 16 chars long; shortening option name would help
knobs to align nicely without having to sacrifice whitespace.
> -.if defined(COLOUR_LESS) || defined(COLOR_LESS)
> +.if ${PORT_OPTIONS:MCOLOUR_LESS}
Option name uses American (that is, correct) spelling of COLOR, but here
you check for COLOUR. This would not work. portlint(1) should have warned
about it.
./danfe
More information about the svn-ports-head
mailing list