svn commit: r318592 - head/benchmarks/mdtest
Boris Samorodov
bsam at passap.ru
Tue May 21 16:28:36 UTC 2013
21.05.2013 06:34, Alexey Dokuchaev пишет:
> On Mon, May 20, 2013 at 10:43:12AM +0000, Boris Samorodov wrote:
>> New Revision: 318592
>> URL: http://svnweb.freebsd.org/changeset/ports/318592
>>
>> do-install:
>> - ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
>> - ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
>> + (cd ${WRKSRC} && ${INSTALL_PROGRAM} ${PORTNAME} ${PREFIX}/bin)
>> + (cd ${WRKSRC} && ${INSTALL_MAN} ${PORTNAME}.1 ${MANPREFIX}/man/man1)
>> .if ${PORT_OPTIONS:MEXAMPLES}
>> @${MKDIR} ${EXAMPLESDIR}
>> - @(cd ${WRKSRC}/scripts && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
>> + (cd ${WRKSRC}/scripts && ${INSTALL_DATA} * ${EXAMPLESDIR})
>
> These changes are gratuitous (at least), plus I've already raised my
> concerns about Kato's desire to make every INSTALL_* command needlessly
> depended on current directory. Not just it makes command line longer,
> it looks worse it logs and requires reader to parse two command instead
> of one. I am also not convinced that using subshell is required.
>
> Asterisk should have been replaced with dot as a safer alternative that
> is not special shell symbol and thus does not require escaping (or worry
> about it).
>
> Given that changes are probably technically correct (Kato is usually good
> on that side), I would like to reinterate that their (or whomever else)
> submissions should not be committed blindly as they are.
First of all this particular commit was not a blind one. And I suspected
that a discussion may take place.
Then I'd say that for me the current state of Makefile is more readable
and more logical:
-----
do-build:
(cd ${WRKSRC} && ${MPICC} ${CFLAGS} -o ${PORTNAME} ${PORTNAME}.c
-lm)
do-install:
(cd ${WRKSRC} && ${INSTALL_PROGRAM} ${PORTNAME} ${PREFIX}/bin)
(cd ${WRKSRC} && ${INSTALL_MAN} ${PORTNAME}.1 ${MANPREFIX}/man/man1)
.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
(cd ${WRKSRC}/scripts && ${INSTALL_DATA} * ${EXAMPLESDIR})
.endif
-----
Said that I don't have a strong position on the matter. If any official
recommendation happen I'll obey it.
Thanks!
--
WBR, Boris Samorodov (bsam)
FreeBSD Committer, http://www.FreeBSD.org The Power To Serve
More information about the svn-ports-all
mailing list