svn commit: r311165 - head/Mk

Alexey Dokuchaev danfe at FreeBSD.org
Wed Jan 30 05:53:08 UTC 2013


On Wed, Jan 30, 2013 at 09:05:52AM +0400, Boris Samorodov wrote:
> 29.01.2013 17:33, Alexey Dokuchaev пишет:
> 
> > +ZSH_DESC?=		Install programmable completions for zsh
> 
> May be this variable should be ZSH_COMPLETION_DESC or like?
> I'd say that current variable name should be used for the
> shell itself.

Yes, variable name is indeed a bit vague.  I've decided to follow the BASH
example for two reasons: 1) consistency; 2) it is not immediately obvious to
me how else a shall can be supported, given that both bash and zsh do not
provide a way to embed themselves anywhere.

> Or for consistency with bash (since bash is one character longer), say:
> ZSH_COMPLETS_DESC
> BASH_COMPLETS_DESC

I think these are quite ugly; I've tried to come up with something like
this and failed.  FOOSH_COMP_DESC is the least ugly I can imagine.

./danfe


More information about the svn-ports-all mailing list