PERFORCE change 130696 for review
Garrett Cooper
gcooper at FreeBSD.org
Wed Dec 12 03:49:21 PST 2007
http://perforce.freebsd.org/chv.cgi?CH=130696
Change 130696 by gcooper at shiina-ibook on 2007/12/12 11:48:28
Use size_t instead of unsigned int (for platform portability?). I just find size_t more consistent with use of sizeof(..).
Affected files ...
.. //depot/projects/soc2007/revised_fbsd_pkgtools/pkg_revised/v2/contrib/libpkg/pkg_db_freebsd.c#6 edit
Differences ...
==== //depot/projects/soc2007/revised_fbsd_pkgtools/pkg_revised/v2/contrib/libpkg/pkg_db_freebsd.c#6 (text+ko) ====
@@ -326,9 +326,9 @@
struct dirent *de;
char *dir;
struct pkg **packages;
- unsigned int packages_size;
+ size_t packages_size;
unsigned int packages_pos;
-
+
assert(db != NULL);
assert(db->db_base != NULL);
More information about the p4-projects
mailing list