FreeBSD 10.2 - LAGG interfaces "possible flapping" during shutdown
Dean Forester
dean_forester at hotmail.com
Tue Oct 6 23:41:37 UTC 2015
Sorry the formatting got all screwed up in the Hotmail Web Interface; hopefully this is more readable.
Sent from my iPad
> Hi,
> Just in case it has an effect on things I have also included the switch side of the configuration below:
> # version 5.20, Release 1513P89
> sysname HP_V1910-24G-PoE
> #
> vlan 1
> arp detection enable
> #
> vlan 101
> description MGMT VLAN - 192.168.1.0/24
> arp detection enable
> #
> vlan 102
> description VLAN 102 - 192.168.2.0/24
> arp detection enable
> #vlan 103
> description VLAN 103 - 192.168.3.0/24
> arp detection enable
> #
> interface Vlan-interface1
> ip address 192.168.0.3 255.255.255.0
> #
> interface Vlan-interface101
> ip address 192.168.1.3 255.255.255.0
> #
> interface Vlan-interface102
> ip address 192.168.2.3 255.255.255.0
> #
> interface Vlan-interface103
> ip address 192.168.3.3 255.255.255.0
> #
> interface Bridge-Aggregation2
> port link-type hybrid
> port hybrid vlan 101 to 103 tagged
> port hybrid vlan 1 untagged
> link-aggregation mode dynamic
> arp detection trust
> #
> interface GigabitEthernet1/0/5
> port link-type hybrid
> port hybrid vlan 101 to 103 tagged
> port hybrid vlan 1 untagged
> stp edged-port enable
> port link-aggregation group 2
> #
> interface GigabitEthernet1/0/6
> port link-type hybrid
> port hybrid vlan 101 to 103 tagged
> port hybrid vlan 1 untagged
> stp edged-port enable
> port link-aggregation group 2
> #
> interface GigabitEthernet1/0/7
> port link-type hybrid
> port hybrid vlan 101 to 103 tagged
> port hybrid vlan 1 untagged
> stp edged-port enable
> port link-aggregation group 2
> #
> interface GigabitEthernet1/0/8
> port link-type hybrid
> port hybrid vlan 101 to 103 tagged
> port hybrid vlan 1 untagged
> stp edged-port enable
> port link-aggregation group 2
> #
> The view of the LAGG from the system side:root at Pine:~ # ifconfig lagg1
> lagg1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
> options=403bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,VLAN_HWTSO>
> ether a0:36:9f:64:6d:d5
> nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
> media: Ethernet autoselect
> status: active
> laggproto lacp lagghash l2,l3,l4
> laggport: igb1 flags=1c<ACTIVE,COLLECTING,DISTRIBUTING>
> laggport: igb4 flags=1c<ACTIVE,COLLECTING,DISTRIBUTING>
> laggport: igb7 flags=1c<ACTIVE,COLLECTING,DISTRIBUTING>
> laggport: igb8 flags=1c<ACTIVE,COLLECTING,DISTRIBUTING>
> The one thing that I just noticed is that I have VLAN 1 untagged on the Bridge Aggregate 2 but I can't see how that would cause this affect. My assumption is that the LAGG interface is being shutdown but the four ethernet ports are not; therefore the kernel notices traffic on all four ports and complains. With this same server I also have another LAGG setup that is going to a Cisco SG200-26 switch (which carries VLAN 104 and VLAN 105) with the same issue. All 8 interfaces show up during the shutdown after the Uptime message with the Interface stopped DISTRIBUTING, possible flapping issue.
> My main concern at this point is how can I do a complete system reboot from remote without it hanging with no access to the power button or console.
> Regards,
> Dean
>
> From: dean_forester at hotmail.com
> To: freebsd-questions at freebsd.org
> Subject: FreeBSD 10.2 - LAGG interfaces "possible flapping" during shutdown
> Date: Tue, 6 Oct 2015 12:28:01 -0400
>
>
>
>
> Hi
>
> I am having an issue with a new FreeBSD 10.2-RELEASE system when using LAGGs. Everything works fine until I try to do a reboot of the system. With this issue the system does a shutdown but reports an error with the interfaces that belong to the LAGG (which also have VLANs define) and then halts, it will not reboot; a power cycle is required.
>
> root at Pine:~ # uname -a
> FreeBSD Pine.local 10.2-RELEASE FreeBSD 10.2-RELEASE #0 r286666: Wed Aug 12 15:26:37 UTC 2015 root at releng1.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC amd64
>
> /etc/rc.conf:
> if_vlan_load="YES"
> # HP V1910-24G Switch Trunk
> ifconfig_igb1="up mtu 1500"
> ifconfig_igb4="up mtu 1500"
> ifconfig_igb7="up mtu 1500"
> ifconfig_igb8="up mtu 1500"
> # Setup new Virtual Interfaces
> cloned_interfaces="lagg1 vlan101 vlan102 vlan103"
> # LAGG Configuration
> ifconfig_lagg1="laggproto lacp laggport igb1 laggport igb4 laggport igb7 laggport igb8"
> # Setup VLANs
> ifconfig_vlan101="inet 192.168.1.208/24 vlan 101 vlandev lagg1"
> ifconfig_vlan102="inet 192.168.2.208/24 vlan 102 vlandev lagg1"
> ifconfig_vlan103="inet 192.168.3.208/24 vlan 103 vlandev lagg1"
> # Setup extra IPs for Layer 3 Load Balancing
> ifconfig_vlan101_aliases="inet 192.168.1.209/32"
> ifconfig_vlan102_aliases="inet 192.168.2.209/32"
> ifconfig_vlan103_aliases="inet 192.168.3.209/32"
>
> Errors on shutdown -r now
>
>
> Uptime: 3d20h44m15sigb8: Interface stopped DISTRIBUTING,
> possible flappingigb1: Interface stopped DISTRIBUTING,
> possible flapping
>
> igb7: Interface stopped DISTRIBUTING,
> possible flapping
>
> igb4: Interface stopped DISTRIBUTING,
> possible flapping
>
>
>
>
>
>
> Has anyone else run into this behavior with LAGGs and VLANs? Any help would greatly be appreciated.
>
> Regards,
>
> Dean Forester
> dean_forester at hotmail.com
>
>
> _______________________________________________
> freebsd-questions at freebsd.org mailing list
> https://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at freebsd.org"
More information about the freebsd-questions
mailing list