git: b7fd9c4e5ebc - main - bhyve/snapshot: rename checkpoint_opcodes to be more generic
Robert Wing
rew at FreeBSD.org
Sat Feb 27 21:45:43 UTC 2021
The branch main has been updated by rew:
URL: https://cgit.FreeBSD.org/src/commit/?id=b7fd9c4e5ebc69934205980d9f628ef8f21fb288
commit b7fd9c4e5ebc69934205980d9f628ef8f21fb288
Author: Robert Wing <rew at FreeBSD.org>
AuthorDate: 2021-02-27 21:03:03 +0000
Commit: Robert Wing <rew at FreeBSD.org>
CommitDate: 2021-02-27 21:03:03 +0000
bhyve/snapshot: rename checkpoint_opcodes to be more generic
Generalize the naming here since the domain socket that uses these codes
might be used for purposes other than the save/restore feature.
- rename checkpoint_opcodes to ipc_opcode
Reviewed by: jhb
Differential Revision: https://reviews.freebsd.org/D28877
---
usr.sbin/bhyve/snapshot.h | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/usr.sbin/bhyve/snapshot.h b/usr.sbin/bhyve/snapshot.h
index caa7256ffbfa..62b2083b9830 100644
--- a/usr.sbin/bhyve/snapshot.h
+++ b/usr.sbin/bhyve/snapshot.h
@@ -60,9 +60,9 @@ struct restore_state {
ucl_object_t *meta_root_obj;
};
-enum checkpoint_opcodes {
- START_CHECKPOINT = 0,
- START_SUSPEND = 1,
+enum ipc_opcode {
+ START_CHECKPOINT,
+ START_SUSPEND,
};
struct checkpoint_op {
More information about the dev-commits-src-all
mailing list