cvs commit: src/sys/kern uipc_mbuf.c uipc_syscalls.c src/sys/net
if_tap.c if_tun.c ppp_tty.c src/sys/netgraph ng_device.c
src/sys/sys mbuf.h
Andre Oppermann
andre at FreeBSD.org
Thu Nov 2 17:37:22 UTC 2006
andre 2006-11-02 17:37:22 UTC
FreeBSD src repository
Modified files:
sys/kern uipc_mbuf.c uipc_syscalls.c
sys/net if_tap.c if_tun.c ppp_tty.c
sys/netgraph ng_device.c
sys/sys mbuf.h
Log:
Rename m_getm() to m_getm2() and rewrite it to allocate up to page sized
mbuf clusters. Add a flags parameter to accept M_PKTHDR and M_EOR mbuf
chain flags. Provide compatibility macro for m_getm() calling m_getm2()
with M_PKTHDR set.
Rewrite m_uiotombuf() to use m_getm2() for mbuf allocation and do the
uiomove() in a tight loop over the mbuf chain. Add a flags parameter to
accept mbuf flags to be passed to m_getm2(). Adjust all callers for the
extra parameter.
Sponsored by: TCP/IP Optimization Fundraise 2005
MFC after: 3 month
Revision Changes Path
1.169 +90 -87 src/sys/kern/uipc_mbuf.c
1.241 +1 -3 src/sys/kern/uipc_syscalls.c
1.64 +2 -1 src/sys/net/if_tap.c
1.160 +1 -1 src/sys/net/if_tun.c
1.70 +1 -1 src/sys/net/ppp_tty.c
1.22 +1 -1 src/sys/netgraph/ng_device.c
1.198 +4 -2 src/sys/sys/mbuf.h
More information about the cvs-src
mailing list