cvs commit: src/sys/netinet tcp_input.c tcp_syncache.c
Andre Oppermann
andre at FreeBSD.org
Mon Jun 26 17:05:35 UTC 2006
andre 2006-06-26 16:14:19 UTC
FreeBSD src repository
Modified files:
sys/netinet tcp_input.c tcp_syncache.c
Log:
Some cleanups and janitorial work to tcp_syncache:
o don't assign remote/local host/port information manually between provided
struct in_conninfo and struct syncache, bcopy() it instead
o rename sc_tsrecent to sc_tsreflect in struct syncache to better capture
the purpose of this field
o rename sc_request_r_scale to sc_requested_r_scale for ditto reasons
o fix IPSEC error case printf's to report correct function name
o in syncache_socket() only transpose enhanced tcp options parameters to
struct tcpcb when the inpcb doesn't has TF_NOOPT set
o in syncache_respond() reorder stack variables
o in syncache_respond() remove bogus KASSERT()
No functional changes.
Sponsored by: TCP/IP Optimization Fundraise 2005
Revision Changes Path
1.302 +1 -0 src/sys/netinet/tcp_input.c
1.97 +33 -45 src/sys/netinet/tcp_syncache.c
More information about the cvs-src
mailing list