cvs commit: src/usr.sbin/bsnmpd/modules/snmp_bridge bridge_if.c
bridge_snmp.h bridge_sys.c
Bjoern A. Zeeb
bz at FreeBSD.org
Fri Dec 29 11:23:39 PST 2006
bz 2006-12-29 19:23:38 UTC
FreeBSD src repository
Modified files:
usr.sbin/bsnmpd/modules/snmp_bridge bridge_if.c bridge_snmp.h
bridge_sys.c
Log:
bridge_snmp.h
* Change the API of bridge_get_basemac to take a maximum buffer length.
bridge_if.c
* Adopt to new API.
* In bridge_attach_newif() remove an additional pointer to the buffer
by shuffling the code a bit. Also makes the code more readable.
bridge_sys.c
* bridge_get_basemac():
- Adopt to the new API.
- Change check for error code of getifaddrs().
- First check for sa_family != AF_LINK.
- Copy sockaddr_dl * to get around alignment constraints on some
platforms.
- Use strcmp instead of strncmp so that "foo11" != "foo1".
* other functions:
- Allocate n times of the struct we need instead of arbitrary len,
cast to the type we want it to be and pass around struct *s instead
of char *s. This gets us around alignment restrictions on some
platforms and in addition it is more clear what data is passed around.
- Name variables for same types consistently.
Reviewed by: syrinx
Revision Changes Path
1.6 +12 -9 src/usr.sbin/bsnmpd/modules/snmp_bridge/bridge_if.c
1.4 +1 -1 src/usr.sbin/bsnmpd/modules/snmp_bridge/bridge_snmp.h
1.5 +77 -65 src/usr.sbin/bsnmpd/modules/snmp_bridge/bridge_sys.c
More information about the cvs-src
mailing list