cvs commit: src/sys/sys mutex.h src/sys/netinet ip_input.c
Robert Watson
rwatson at FreeBSD.org
Mon Mar 1 14:37:04 PST 2004
rwatson 2004/03/01 14:37:02 PST
FreeBSD src repository
Modified files:
sys/sys mutex.h
sys/netinet ip_input.c
Log:
Rename NET_PICKUP_GIANT() to NET_LOCK_GIANT(), and NET_DROP_GIANT()
to NET_UNLOCK_GIANT(). While they are used in similar ways, the
semantics are quite different -- NET_LOCK_GIANT() and NET_UNLOCK_GIANT()
directly wrap mutex lock and unlock operations, whereas drop/pickup
special case the handling of Giant recursion. Add a comment saying
as much.
Add NET_ASSERT_GIANT(), which conditionally asserts Giant based
on the value of debug_mpsafenet.
Revision Changes Path
1.266 +2 -2 src/sys/netinet/ip_input.c
1.69 +10 -4 src/sys/sys/mutex.h
More information about the cvs-src
mailing list