cvs commit: src/sys/ia64/ia64 machdep.c trap.c unwind.c
src/sys/ia64/include md_var.h unwind.h
Marcel Moolenaar
marcel at FreeBSD.org
Sat Jul 10 15:59:31 PDT 2004
marcel 2004-07-10 22:59:30 UTC
FreeBSD src repository
Modified files:
sys/ia64/ia64 machdep.c trap.c unwind.c
sys/ia64/include md_var.h unwind.h
Log:
Update for the KDB framework:
o ksym_start and ksym_end changed type to vm_offset_t.
o Make debugging support conditional upon KDB instead of DDB.
o Call kdb_enter() instead of breakpoint().
o Remove implementation of Debugger().
o Call kdb_trap() according to the new world order.
unwinder:
o s/db_active/kdb_active/g
o Various s/ddb/kdb/g
o Add support for unwinding from the PCB as well as the trapframe.
Abuse a spare field in the special register set to flag whether
the PCB was actually constructed from a trapframe so that we can
make the necessary adjustments.
md_var.h:
o Add RSE convenience macros.
o Add ia64_bsp_adjust() to add or subtract from BSP while taking
NaT collections into account.
Revision Changes Path
1.180 +9 -17 src/sys/ia64/ia64/machdep.c
1.102 +12 -11 src/sys/ia64/ia64/trap.c
1.11 +169 -80 src/sys/ia64/ia64/unwind.c
1.17 +29 -8 src/sys/ia64/include/md_var.h
1.6 +5 -1 src/sys/ia64/include/unwind.h
More information about the cvs-src
mailing list